Configuring And Installing DAME

Installing DAME is not very a complicated task. You need to have Antlr and CPPUnit installed on your system before you can install DAME. DAME uses Antlr version 2.7.1 and CPPUnit 1.8.0. Any later versions of these tools might be OK for installing DAME.


Checking Dependencies


java antlr.Tool

Should give the version number. The version should be >= 2.7.1

GCC 3.x

g++ --version

Should print the version number (with whole lot of other information). The version should be >= 3.0


Check whether the libcppunit is available for linking. You need the header files of CPPUnit accessible to the DAME compilation process.


DAME needs atleast one supported Database to be of use for development. At the time of writing this Primer DAME has support for Oracle™ 8i/9i and Postgresql. The configuration script for DAME looks at ORACLE_HOME environment variable for compiling Oracle™ support. Similarly DAME configuration script checks and executes pg_config script to build support for Postgresql.


  1. ./configure

  2. make

  3. su

  4. make install